Наши сертификаты Наши сертификаты

Партнерская программа Партнерская программа

Юридическим
лицам
Оставить заявку

8 (495) 232-52-16 для Москвы

8 800 200-22-33 для бесплатных звонков из России

? Хотите
скидку?
Получить скидку

Главная > Блог > Функция ПРОСМОТРX в редакторе таблиц «Р7-Офис»

Функция ПРОСМОТРX в редакторе таблиц «Р7-Офис»

07.12.2023 / 11:07 630 0 0 Все новости
Функция ПРОСМОТРX в редакторе таблиц «Р7-Офис»

Многие пользователи электронных таблиц знакомы с функцией ВПР, которую используют для поиска и подстановки данных из большой таблицы. Однако ВПР имеет свои ограничения и часто требует для достижения результата использовать и другие формулы. Благодаря недавно представленной функции ПРОСМОТРX в Р7-Офис, все эти сложности остались в прошлом.

Как правильно применять?

Функция ПРОСМОТРХ используется для поиска информации в сложных таблицах, когда нужно найти данные, соответствующие определенному критерию. Например, если у вас большой каталог, и вы хотите найти определенный артикул, или если у вас есть информация о рейтинге студентов, и вы хотите узнать текущий рейтинг одного из них, функция ПРОСМОТРХ поможет вам получить нужную информацию. Она также может понять что информация отсутствует, если, например, студент был отчислен, или если артикул был внесен в каталог под другим названием.

Функция ПРОСМОТРХ имеет следующий синтаксис: 

=ПРОСМОТРХ(искомое_значение; просматриваемый_массив; возвращаемый_массив; [если_ничего_не_найдено]; [режим_сопоставления]; [режим_поиска])

Важно отметить, что функция ПРОСМОТРX работает только с латинской буквой “Х” на конце, поэтому необходимо правильно писать название функции.

Три обязательных параметра:

  • – искомое_значение – это значение, которое вы хотите найти в просматриваемом массиве;

  • – просматриваемый_массив – это диапазон ячеек, в которых будет производиться поиск;

  • – возвращаемый_массив – указывает, какую информацию вы хотите получить из просматриваемого массива, по строке или по столбцу.

Три необязательных параметра:

  • – если_ничего_не_найдено – значение, которое будет возвращено, если искомое значение не найдено;

  • – режим_сопоставления – тип сопоставления (точное совпадение, приблизительное совпадение или отсутствие соответствия);

  • – режим_поиска – направление поиска (от верхней левой ячейки к нижней правой или наоборот).

Как пользоваться?

Чтобы продемонстрировать возможности функции ПРОСМОТРХ, используем тестовую таблицу с данными о поставках продуктов в разные города, на разные суммы и в разные даты. Затем покажем несколько примеров использования этой функции. На вкладке “Формула” нажимаем кнопку “Функция” и в открывшемся меню выбираем “ПРОСМОТРХ”.

Поисковой запрос с помощью ПРОСМОТРХ

Пример 1. Поиск информации по определенному товару

Чтобы функция ПРОСМОТРХ работала корректно, необходимо убедиться, что кавычки, используемые в формуле, имеют правильный формат. В данном случае, необходимо использовать правильные кавычки, в виде запятых, «ёлочки» не подходят.

=ПРОСМОТРX(J4;A1:A24;F1:F24; “не завозили”)


Результат выполнения запроса

Пример 2. Обратный поиск

Для того, чтобы найти самые последние по дате сведения, необходимо изменить параметры функции ПРОСМОТРХ. Добавить параметр “режим поиска”, который указывает направление поиска (от верхней левой ячейки к нижней правой или наоборот).

Новая формула будет выглядеть следующим образом:

=ПРОСМОТРX(J4;A1:A24;F1:F24;”не завозили”;0;-1)

Здесь параметр 0 означает точное совпадение, а параметр -1 указывает, что необходимо искать последнее значение в столбце.


Пример обратного поиска

Преимущества функции ПРОСМОТРХ

При сравнении функции ПРОСМОТРX с ВПР можно выделить несколько ключевых преимуществ:

  • Не требует указания точного номера столбца для получения данных. Достаточно указать диапазон. Функция остается работоспособной даже при добавлении новых столбцов.

  • Позволяет извлекать значения из столбца, даже если он находится слева от идентификатора.

  • Имеет удобный режим обратного поиска с последнего значения.

  • Тип сопоставления является необязательным параметром. По умолчанию функция ищет точное совпадение.

  • Работает как с вертикальными столбцами, так и с горизонтальными строками.

Функция ПРОСМОТРХ может использоваться для решения различных задач, связанных с обработкой данных в таблицах: можно вставить ПРОСМОТРX в ПРОСМОТРX или обеспечить взаимодействие между несколькими таблицами для объединения информации из разных источников. Возможности практически безграничны.

Поделитесь в комментариях, есть ли у вас опыт работы с ПРОСМОТРX? Если нет, то планируете ли попробовать?

0 0
Оставить комментарий
Ваш комментарий отправлен на модерацию и будет опубликован после проверки
К сожалению, добавление комментариев доступно только после авторизации на сайте
Всего 0 комментариев

Каталог
Разработчики

Спасибо! Вам отправлен e-mail с подтверждением подписки. Спасибо. Вы успешно подписаны. Пожалуйста, введите e-mail Неверный e-mail Вы уже подписаны на данную рассылку
Широкий ассортимент
Можем поставить любое ПО и оборудование, продающееся в РФ. Заказываем редкие программы, в том числе не представленные на сайте.
Официальные поставщики
Всё ПО и оборудование поставляются через официальных дистрибьюторов. Программы предназначены для активации на территории России.
Скидки постоянным клиентам
Сделав первую покупку, вы автоматически получаете скидку на следующий заказ.
Быстрая доставка
Доставляем ПО на email от 10 минут. Физические товары доставляем с курьером по всей России.
Вы используете устаревшую версию браузера .
Наш сайт построен на передовых и современных технологиях, поэтому при использовании устаревших версий браузера некоторые элементы могут отображаться некорректно.
Мы рекомендуем вам обновить браузер до последней версии.